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EXO Business
This training manual has been 
developed by the MYOB Enterprise 
Division - Professional Services Team 
for use in the delivery of training.

This manual uses a simple step-by-step 
approach to give you the skills and 
knowledge necessary to create Clarity 
files your EXO Business system.

This manual has been designed for the 
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Participants
This course is aimed at:

• Users of EXO Business.

Prerequisites
Basic PC experience is required.
Understanding of payroll processes and procedures.

Instructional method
The instructional method combines trainer-led demonstrations with hands-on student 
practice. You will work through a series of examples. Each unit concludes with a Review 
Task. 

Conventions used in this manual
• Objects such as buttons or icons that you must click or select are shown in bold.
• Information to be entered (typed in) is shown in bold and italics.
• Keyboard keys are shown as , , etc.

Screenshots in this manual are for illustration purposes only and may differ from those in 
the actual product due to configuration settings.

This manual assumes a basic understanding of databases and a general understanding of 
the operation and table structure of EXO Business. For more information on these topics, 
refer to ‘Appendix A - Database Primer’ on page 94 and ‘Appendix B - Key EXO Business 
Tables’ on page 96.



Clarity (Beginners’) EXO Business
Symbols used in this manuals

Symbol Name This symbol tells you... 

Practice task

Review task

… to complete a task to practice the skills you 
have just learnt, or as a review task at the end 
of the unit to consolidate what you have learnt.

Written Review task … to complete written questions to review the 
content covered in the unit.

Optional Challenge … to complete this task if you have finished 
early and are looking for an extra challenge.

Tip … about helpful tips

Note … to take note of an important message.

Warning … about potential problems to be aware of.

Important … to pay attention to an important notice.

New … where features are new for EXO Business.

Reference … where to go to find more information.

Skills Checklist … to tick off a list of skills that you have learnt 
during the unit.
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Objectives

In this coure you will learn how to use Clarity to create your own custom files.
Upon completion of this course you will be able to:

• Identify Clarity form types

• Navigate around Clarity tabs

• Understand Canvas and Pallette usage

• Create Data sets

• Add fields to a report

• Position and Alignment

• Utilise Grouping 

• Add correct parameters

• Join Multiple Tables

• Create Calculated Fields

• Limit content via the search tab

• Specify Sort Orders

• Use the Report Wizard

• Hide Bands & Fields

• Create Merge files
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Navigational & Function Keys

MYOB EXO Business can be navigated by keyboard or mouse, however a combination of 
both is generally used. The standard keyboard convensions for Windows are used, with a 
few MYOB EXO Business-specific options.

Shortcut Menus
A shortcut menu is available at the top of the main window of each EXO Business module. 
This menu offers quick access to commonly used functions, e.g. accessing the Debtors 
Masters, accessing the Stock Masters, creating a new Sales Order, etc. Any menu item that 
has a shortcut key assigned will automatically appear in the shorcut menu.

Windows Navigation Keys

TAB Moves from field to field, column to column

SHIFT+TAB Moves backwards from field to field, column to 
column

ENTER On open dialogue boxes, automatically select the OK 
button.

ARROW KEYS Moves around a grid, or up and down a list.

PAGE UP, PAGE DOWN Moves between the “sections” of some screens, 
such as moving from the invoice header to the body 
to the end.

ALT + (Underlined Letter) ALT key plus the underlined letter on a field label 
activates that function, e.g. ALT + N within a the 
debtor account screen creates a New Debtor.

Shortcut Menus
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Orientation
In this unit you will lear 
how to navigate around 
Clarity.
By the end of this unit, you will be able to:

Identify Clarity form types

Familiarise yourself with all work tabs

Canvas set up

Understand pallette tools

Utilise drop down menu options
 1



Clarity (Beginners’) EXO Business
Overview

Clarity is the MYOB EXO Business report writer especially written for use with Exo 
Business. The Report Designer is the application you will use to build EXO Business reports. 

Clarity Report Types
There are four kinds of clarity report types in EXO Business.

Clarity reports (.CLR) 
This is the most commonly used report type. Each CLR can have its own set of runtime 
parameters stored as a .CLS file and can be run from a menu, the command line, custom 
buttons, etc. CRL files can be given any name and there can be any number of them

Clarity Business Forms (.CLF)
Specific Clarity Forms are identified with specific functions within EXO Business. These are 
essential business forms that are part of the usual business workflow. In contrast, Clarity 
Reports (CLRs) can be placed on the EXO Business menu or run via the command lin. 
A few notable exceptions exist however. Examples include where you are using a variety of 
invoice forms and they are specified by on the Debtor Account Details > Details 2 tab - 
Invoice file number - e.g. Invoice1.CLF, Invoice2.CLF - or if you have set up you system to 
prompt you to select from a list of formats when you save an invoice or sales order.
Another characteristic of a CLF file is that it is automatically passed a single key value, such 
as a transaction record number or an account number to the data pipeline named Master 
in your CLF definition. 

For example:
EXO Business will pass the DR_Trans Seqno to the file named Invoice.CLF. Therefore the 
DR_Trans.Seqno field must be in the data pipeline named "Master" on the data tab in 
Clarity.

Clarity Merge Files (.CLM)
CLM files are used to produce clarity merge files. These are similar to Mail Merge in 
Microsoft Word, which incorperate data fields.

Clarity Email Files (.CLE)
CLE Files are used along side certain CLF files to produce default email Subject & Body text. 

Example:
When sending out an invoice, you can have a default message that accompanies the pdf 
file.
© Copyright 2012 MYOB Technology Pty Ltd
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Unit 1—Orientation
N O T E
Refer to the Clarity Report Masters document for a listing of the currently supported 
CLR,CLF & CLM files.

Report Designer Tabs
Clarity contains four main tabs: 

• Data

• Design

• Preview, and 

• Detail

• Calc, which is reserved for more advanced development.

Design Tab
When first loaded, the EXO Business Report Designer defaults to the Design tab 
workspace. This is where you will spend the majority of your report-building time. 
The Design workspace is divided into two areas: 

• the workbench, and 

• the canvas. 

The workbench comprises toolbars, component palettes, rulers and other tools that can 
be used to manipulate the canvas. 

Clarity Main Tabs

Clarity Main Palette
© Copyright 2012 MYOB Technology Pty Ltd
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The canvas is the area that contains the report layout. This is where we place the bands (or 
sections) and components that will ultimately control the content of each page of the 
report.

All bands, with the exception of the Detail band, can be either shown or hidden by 
selecting or unselecting the appropriate option under the Report menu.

Preview Tab
The Preview tab plays an integral role in the report-creation process. It allows you to see 
how the report will look when printed. 
As you work through the tutorials, you'll notice that this tab is frequently accessed so that 
we can see how the report is progressing. We will make many changes and corrections 
based on what we see in this tab. 

Clarity Canvas

Band Description

Title The Title band contains the title of the report and prints on the first 
page only.

Header The header band prints at the top of each page.

Detail The detail band prints once for every row of data.

Footer The footer band prints its on the bottom of each page.

Summary The summary band prints once at the end of a report. The band is 
typically used to summarize data.

Page Style The page style band allows you to set components (for example, 
images or watermarks) as a background for each page of your report. 
This is typically only used in advanced reports.
© Copyright 2012 MYOB Technology Pty Ltd
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Unit 1—Orientation
The tools in this tab allow you to view each page of the report or zoom in to get a better 
look at a specific page. You can browse on screen or you can print the report from the 
preview tab.

Data Tab
The Data tab is the key to successful report creation. It allows us to select and manipulate 
the source data needed for a given report. These tasks are accomplished via two visual 
tools: 

• the Query Wizard, and 

• the Query Designer. 

These tools greatly simplify the often-difficult task of data selection by giving us the ability 
to select data without requiring too much in-depth knowledge of the underlying EXO 
Business database structures. 
Either of these methods can be used to achieve the same result. The Wizard leads the user 
step-by-step through the process, whereas the designer is a quicker way for more 
advanced users to select the data they want.
The options on the main drop down menus at the top of the screen change when you 
move to this tab. By selecting one or more tables and joining these tables where needed, 
Data pipelines can be constructed containing only the data required in your report. This 
gives the benefit of speed, as the subset of data is smaller and any heavy processing is 
performed on the server. 

Preview Tab
© Copyright 2012 MYOB Technology Pty Ltd
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The example below shows the data tab with a number of data pipelines. The coloured lines 
between the data pipelines represent the links between them. They link specific fields to 
each other and are often slower than the table joins within the data pipelines, but there 
are extra benefits with these, which will be explained later.

Detail Tab
This tab is the equivalent of the powerful Report to Grid option in early EXO Business 
versions. It displays the data obtained from the data source that has been selected for the 
primary detail.  The specific EXO Business component procedure can be selected when 
double-clicking on the line in the details band of the report. 
All the usual options of Account Maintenance, Stock Item Maintenance, General Ledger 
Account, Sales & Purchase Order and Invoice are available. User profile security policies 
will still apply when these functions are called.
The dropdown list entitled Click To should be changed to select what you would like to drill 
down to. 

Data Tab
© Copyright 2012 MYOB Technology Pty Ltd
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For example:
In a Debtors Invoice Listing Report it is possible to drilldown to either the Debtors 
Account or the Debtors Invoice.

T I P
It is recommended that you save your reports regularly. You may also wish to save a copy of the file in 
a different folder immediately before making major changes, in case you need to revert to an earlier 
version.

N O T E
You cannot edit in the preview pane.

Detail Tab
© Copyright 2012 MYOB Technology Pty Ltd
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Data Tab

Overview
The Data tab is where the database tables and fields are selected. This section will explain 
the process of such selection, as this is an important part of the report writing process. If 
no data or the wrong data is extracted, the final report will show incorrect results.  
This section also discusses the use of the Query Designer, as it is most likely the one you 
will choose to use. In the interests of completeness, the use of the Query Wizard is 
illustrated in the example included in ‘Task 3: Generate the Report via the Report Wizard 
method’ on page 79. 

To create a new data pipeline:

1 From the Clarity Report Designer, click on the Data tab so that you see a grey screen 
with only the menu option of File available. 

2 Select File > New and double-click on the Query Designer icon.

Query Designer
The Query Designer has 8 tabs:

• Tables

• Fields

• Calcs

New Data Set
© Copyright 2012 MYOB Technology Pty Ltd
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• Search

• Group

• Group Search

• Sort, and 

• SQL. 

These are explained in further detail later.

Tables Tab
This tab privides a list of available tables and views in the database for the user to choose 
from. The screen will now be split into 2 panes. The upper pane displays all of the EXO 
Business database tables available for use in report writing. The lower pane displays all the 
EXO Business database tables that have been selected for the report.

When you first create a new data pipeline the bottom pane will be blank.  This is where 
your selection will be stored. 
To select items on any of the tabs, double-click on a line in the top pane (in this case a 
table) and the line will copy into the bottom pane. 

For example:
Double-click on DR_TRANS in the top pane to add it to the bottom pane.  If you then 
decide that you have made a mistake and want to remove it from your selection, simply 
double click on it in the lower pane and it will disappear. 

Data Tables Tab
© Copyright 2012 MYOB Technology Pty Ltd
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If you click on the OK button at this stage after only selecting a table, you will receive an 
error message. This is because no data fields have been selected and selecting a table on 
its own without fields is of no use.
If you select a second or subsequent table, the following screen will appear:

In this dialog box you can create a table join. A table join links two tables based on a 
common field. 

To add a join condition: 

1 Select the type of join

• Inner
• Left Outer
• Right Outer
• Full Outer.  

T I P
If you are unfamiliar with these terms, refer to ‘Appendix A - Database Primer’ on page 94 
for more information.  

2 Select the table to which you want to join from a list of existing tables in the data 
pipeline.

3 Highlight the new table's join field (on the left).

4 Select the existing table's join field (on the right) and click Add.

In the example above we are inner joining the DR_ACCS table (new) to the DR_TRANS 
table (existing) via the Accno field.  

Data Tables Join
© Copyright 2012 MYOB Technology Pty Ltd
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All unnecessary joins listed in the Joined Fields box must be removed or you may not get 
the results you intended 

T I P
Clarity adds joins between fields of different tables with the same name automatically.

N O T E
Table joins within a data pipeline (like that shown above) occur on the server. This means 
that the server (which is designed for this type of processing) can manipulate the data 
more quickly and your report will display or print more quickly.  If all you need is a single 
source of data (ie. no sub-reports or complex selections), then this is the best way to join 
two tables.

Fields Tab
Once you have selected the tables you require, click on the Fields tab.

The selection of fields is the same method as before (double-clicking) with one exception: 
When you choose a field, it disappears from the top pane and only appears in the bottom 
pane. This means that, although you can choose the same table more than once, you 
cannot choose a field more than once from the same instance of that table. 

N O T E
In the bottom right quadrant of the screen there is an All fields option. As the name 
suggests, if selected, all of the fields in the top pane will now be selected and will appear in 
the bottom pane.  Changes can then be made by unselecting any unnecessary fields.

Data Fields Tab
© Copyright 2012 MYOB Technology Pty Ltd
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It is important to keep in mind that the more fields you select, the greater the amount of 
data that the computer will have to sift through when running a report. Consequentially, it 
will take longer to run. It is a advisable to only use the fields you need. If you later find that 
you need more fields, you can access this screen again and add them.

Calcs Tab
The Calcs tab is where simple mathematical calculations are performed. 

To record a calculation:

1 Select any field from the top pane.

2 Double-click on it to move it down to the bottom pane.  

3 Select a function from the dropdown list, depending on the calculation you wish to 
apply to the field (e.g. Sum( ), Count( ), etc.). Alternatively, select the expression 
option for a more complex calculation and enter your formula.  

4 Enter an alias for the resulting field in the Field Alias.

For example: 
If you only had the amount and the exchange rate fields available, but you need to 
display the foreign currency of an amount of money, you would need to perform a 
calculation. To calculate the foreign currency amount you would enter the expression 
(amount/exchrate) and then rename the alias to FCAmount. 

As in the other tabs, double-clicking sends the line back to where it came from.

Data Calcs Tab
© Copyright 2012 MYOB Technology Pty Ltd
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Search Tab
The Search tab is where selection criteria is entered in order to narrow down the selection 
of data to be as small as possible. 

For example:
You can filter the records based on a date range or where balances are greater than 
$0.00.  

Any number of filters can be added to narrow down the result set.

T I P
As Clarity does not have an easy facility to enter a sample size, use the search screen to make your 
sample size as small as you need it to be so that your report runs quickly whilst you are building and 
testing. However don't forget to remove the unwanted search criteria before installing your report in 
a live situation.

Group Tab

Unless you are familiar with grouping, you may wish to ignore this tab as there are easier 
methods of grouping in the report itself.  If you add an aggregate function (e.g. Sum( ) ) in 
the Calcs tab, Clarity will automatically add non-aggregated fields to the list of fields to 
group by.  This is normal behaviour and you cannot remove these.

Group Search Tab
The Group Search tab is where selection criteria is entered in order to narrow down the 
selection of data to be as small as possible. Similar to the Search tab, this feature is used to 
limit data further at a group level, e.g. You may want to exclude any Debtors Accounts who 
have an account balance of $0.00.

Sort Tab
The Sort tab is useful to select the order in which data is listed on the report. 

Data Search Tab
© Copyright 2012 MYOB Technology Pty Ltd
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If you are grouping by fields other than using the data pipeline Group tab (i.e. using the 
Report > Groups menu option, which is the recommended option at this stage), it is 
essential that the fields that you order by are the same fields that you group by and in the 
same order.  Once these fields have been added in the correct order, any further fields can 
be added to sort records within the group. 

For example:
In order to correctly group records in a report by debtor account, you must have the 
records sorted by debtor account.  You could then add a Sort field for the invoice 
number to sort by invoice number within the debtor account.

Data Sort Tab
© Copyright 2012 MYOB Technology Pty Ltd
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SQL Tab
The only editable part of the SQL tab is the Name field, which actually is the name you give 
the new data source / data pipeline. The rest in the greyed out area shows the commands 
that you have performed on the tables and fields turned into SQL. Thus, if you are familiar 
with SQL code, this tab provides a useful check to see that you have made the selections 
you intended.

N O T E
In the above example, the data source has been renamed to 'Master'.  This is because EXO 
Business looks for a data source named Master to apply search criteria to when passing 
parameters such as transaction sequence numbers through to reports.

Creating a Data Source
One of the more difficult parts of creating a report is working out which tables and fields 
you need to select to obtain the required information.
You first need to make a list of all the fields you want to display on your report.  A good 
way of achieving this is by creating a rough drawing of what you would like your report to 
look like when it prints out (displaying a line or two of example data).  You can then make a 
list of the fields required to show this information.
If any of the fields you require are calculated fields, you need to work out from which 
field(s) they will be calculated and add those source fields to the list of required fields.
Once you have determined which fields you require, make a list of all of the distinct tables 
that the fields come from.  Establish how these tables are linked in the database, i.e. which 
fields they are linked on.

Dat SQL Tab
© Copyright 2012 MYOB Technology Pty Ltd
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You now have all of the information required to create a data source and it is just a matter 
of selecting the distinct tables in your new data source and joining them with the links 
established. The fields required can then be selected for use in your report directly or to 
within calculations.
The report exercises in subsequent units guide you through this process, step-by-step .
© Copyright 2012 MYOB Technology Pty Ltd
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Workbench Toolbars

This section introduces you to the various toolbars and their functions.
You can view a list of all toolbars in EXO Business Clarity and select those that you wish to 
always show, by selecting the View > Toolbars option from the Report Designer main 
menu or by right-clicking over the grey area of the workbench (i.e. the toolbars and 
component palettes). It is recommended that you select all the toolbars and become 
familiar with each.

Toolbars
Standard Component Palette
The Standard Component palette and the Data Component palette would appear at a 
glance to contain many of the same elements. Although the similar icons do similar things, 
their overall purpose is very different. 
The Standard Component palette is usually used for headings, labels, company logos, etc., 
that are static and not tied to any data source. The Data Component palette is the set of 
tools that are used to actually extract data from the database.

Design Tab View Menu

Standard Component Palette
© Copyright 2012 MYOB Technology Pty Ltd
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The icons on the Standard Component palette represent components that are frequently 
used to build reports. 

To use a component:

1 Click on an icon. 

2 Click in a report band.  

The functionality of each tool is described below.

1 Selection tool - Selects one or more components within the layout. It also allows you 
to clear any selection (by clicking in the white space of a band).

2 Label - Displays text. To set the caption of a label, highlight 'Labelx' which appears in 
the white window below this toolbar and overwrite it with the text you require. The 
label must be selected before this can be done. You also have the option to double 
click on the label to make it active to overtype. From 8.4 the label allows via Right 
Click > Position the ability to alter the angle. This replaces the Rotated Label in 
previous versions

3 Memo - Prints multiple lines of plain text in a report. This can be achieved by editing 
the white window as with the label or by right-clicking on the Memo block on your 
canvas and selecting lines. You will be presented with a small word processing-type 
window in which you can type the text you require. This tool has limited word 
processing capabilities unlike the Rich Text tool described below.

4 RichText - Prints formatted text. Right-click on this block on your canvas and select 
Edit to access the window and its word processing features.

5 System Variable - Displays common report information such as page number, page 
count, print date and time and current date and time. When first seleted, it defaults 
to Date. Clicking on the dropdown list allows a number of other available options.

6 Variable - Performs calculations. This tool is used together with the Calc tab and is 
used for advanced calculations.

7 Image - Displays graphics such as bitmaps, GIFs and JPEGs. This is used where a 
company logo is required on a form.

8 Shape - Displays various shapes, such as squares, rectangles, circles and ellipses. It 
initially defaults to a Rectangle. Uuse the dropdown list in the top right hand corner 
of the screen to select a different shape. In 8.4 you can set the Gradient colouring 
using Properties Tree> Gradient.

9 Line - Displays a line. Use the Edit toolbar to set the line orientation to top or 
bottom, left or right. 
© Copyright 2012 MYOB Technology Pty Ltd

 18



Unit 1—Orientation
10 BarCode - Renders text as a barcode. Use the Edit toolbar to set the text to be 
encoded. Right-click and access Configure to select from a list of industry standard 
bar code types.

11 2D Barcode - Renders a two-dimensional barcode. Use the Edit toolbar to set the 
text to be encoded. Right-click and access Configure to select from a list of industry 
standard bar code types.

12 Chart - Renders a chart based on fixed data.  Right-click and select Edit Chart to 
configure the type and properties of the chart you wish to display. Chart or DBChart 
components are outside the scope of this training manual.

13 Checkbox - Displays a checkbox icon that can be set as checked or unchecked by 
right mouse click.

14 Total Variable - Used to perform totals for groups and reports. This is configured by 
right-clicking, selecting Grand Total and then selecting the field to be totalled from 
the dropdown list.

15 Gradient box - This tool allows you to create a box with a coloured gradient fill.  This 
can be useful for to make reports more modern-looking, but it should be used 
sparingly.

Data Component Palette

As described previously, Data Component palette offers several components that are 
identical to the standard palette, except that they are data aware, also known as data 
bound.
Data aware components have the ability to read the value of a field from a database table 
at run-time and then display that value in the report. This is different from the standard 
components, which display the content assigned when you lay out a report (design-time). 
You associate a data aware component with a given data pipeline and field by selecting the 
pipeline and field from dropdown lists in the Edit toolbar (the 2 white boxes with 
dropdown capabilities located in the top left of your screen).

1 DBText - Displays data from most types of database fields. It cannot handle images 
or Rich Text.

2 DBMemo - Prints plain text from a memo field of a database table. It will 
automatically word-wrap the text and can be set to stretch vertically down the page 
to accommodate larger text fields.

3 DBRichText - Prints formatted text from a memo field. It will automatically word-
wrap the text.

Data Palette
© Copyright 2012 MYOB Technology Pty Ltd
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4 DBCalc - Performs simple database calculations (Sum, Min, Max, Average, Count). 
Placing one of these on your report will result in a box containing "Sum(?)".  To 
replace the ? with the database field to be manipulated, select the field from the 
dropdown list of fields in the top left of your screen. To replace Sum with one of the 
other functions, right-click on the box and select Calculations.

5 DBImage - Prints graphics (Bitmaps, GIFs, JPEGs) that are stored in a database field.

6 DBBarCode - Renders a database field as a barcode. Use the dropdown list of 
database fields to set the Database field to be encoded. Right-click and access 
Configure to select from the list of industry standard bar code types.

7 2D DBBarcode - Renders a database field as a two-dimensional barcode. Use the Edit 
toolbar to set the text to be encoded. Right-click and access Configure to select from 
a list of industry standard bar code types.

8 DBCheckbox - Displays a checkbox for a Boolean value in the database. Select the 
table and field from the dropdown lists.  You can also set the BooleanFalse and 
BooleanTrue properties of the checkbox in the Properties sidebar. Boolean True and 
Boolean False represent the 'field value to produce a check' and 'field value for an 
uncheck'.  You could also replace the 1 and 0 in the illustration below with the value 
contained within the database field.

9 DBChart - Displays a chart based on one or more data series from the defined data 
pipelines.  Right-click and select Edit Chart to configure the type and properties of 
the chart you wish to display. Chart or DBChart components are outside the scope of 
this training manual.

DB Check Box Properties
© Copyright 2012 MYOB Technology Pty Ltd
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Standard Toolbar

The Standard toolbar allows you to perform basic functions such as opening, saving and 
printing reports, as well as cutting and pasting selections.

1 New Report - Creates a blank report.

2 Open Report - Displays the Open dialog, allowing you to open an existing report.

3 Save Report - Saves a report to file.

4 Page Setup - Displays the Page Setup dialog, allowing you to set the paper size and 
configure the layout for the report.

5 Print - Displays the Print dialog before sending the report to the printer.

6 Print Preview - Displays the Preview tab.

7 Cut - Places the currently selected components in the clipboard and removes them 
from the report canvas.

8 Copy - Copies the currently selected components into the clipboard.

9 Paste - Pastes the components in the clipboard into the report layout.

T I P
Clarity provides the ability to paste components or sets of components between reports.  This can be 
useful when copying layouts from one report into another. 

N O T E
Be sure to check that the data aware components pick up the correct data field and 
reassign them where necessary. Note that any Variable expressions or Calcs code will not 
be transferred across, so this needs to be entered manually.

Format Toolbar

Use the Format toolbar to set the font and colours of text-based components. You can also 
control the layering of components with this toolbar.

1 Font Name shows the name of the font chosen for the selected component.

Standard Features Palette

Format Palette
© Copyright 2012 MYOB Technology Pty Ltd
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2 Font Size shows the size of the font chosen for the selected component.

3 Bold sets text to bold.

4 Italic sets text to italic.

5 Underline underlines text.

6 Left Justify left-justifies text.

7 Centre centres text.

8 Right Justify right-justifies text, as would be usually used for numbers

9 Fully Justify fully justifies paragraphs of text, usually used in memo fields.

10 Font Colour sets the text colour.

11 Highlight Colour sets the background colour.

12 Anchor allows the control to reposition itself when layout changes.

13 Border property for all controls.

14 Bring Forward brings the component forwards a layer.

15 Bring to Front brings a component to the front of other components.

16 Send Backwards bring a component back a layer.

17 Send to Back sends a component to the back of the other components. You can use 
the Report Tree to see the exact layering of the components within the band.

Draw Toolbar

The Draw toolbar is used to set the colour and style used by shape, line and region 
components.

1 Fill Colour sets the colour for a shape or region.

2 Line Colour sets the colour of the border for shapes and regions. Sets the colour for 
a line.

3 Gradient allows to set the gradient colouring if you have a for the standard shape 
component. This gives you extra functionality as all types of shape can be used.

4 Line Thickness determines the thickness of a line. Applies to line components only.

5 Line Style sets the style of a line.

Draw Palette
© Copyright 2012 MYOB Technology Pty Ltd

 22



Unit 1—Orientation
Edit Toolbar
The Edit toolbar is unique in that it changes based on the selected component. It consists 
of 2 dropdown lists used with the following components: 

• Data aware components 

• Labels 

• Shapes 

• Lines 

Edit Toolbar with data aware component

This configuration allows the data pipeline (1) and data field (2) for the component to be 
set.

Edit Toolbar with a label component

This configuration allows you to type the text for a Label

Edit Toolbar with a shape component

The Edit toolbar allows you to choose from several shapes when a shape component is 
selected.

Database Selection

Label Edit

Shape Selection
© Copyright 2012 MYOB Technology Pty Ltd
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Edit Toolbar with a line component

This configuration allows you to move the line to the top, bottom, left or right within a line 
component.

Nudge Toolbar

The Nudge toolbar is useful when you want to move a component or selection of 
components with precision. Select a label on your report by clicking on it and then try 
clicking on each icon in turn.
The arrow on each icon represents the direction the selected item will move. Selections 
will move one pixel at a time.  You can also move selected objects one pixel at a time by 
using the Ctrl-[Arrow Key] key combination.

1 Nudge up moves all selected components up one pixel.

2 Nudge down moves all selected components down one pixel.

3 Nudge left moves all selected components one pixel to the left.

4 Nudge right moves all selected components one pixel to the right.

Size Toolbar

You can use the Size toolbar to set all of the components within a selection to a uniform 
height or width.

1 Shrinks the Width of all selected components to the width of the narrowest.

2 Increases the Width of all the selected components to the width of the widest.

3 Shrinks the Height of all selected components to the height of the shortest.

Line Selection

Nudge Palette

Size Palette
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4 Increases the Height of all the selected components to the height of the tallest.

Select a small label from the detail band on the report and then, while holding down the 
Shift key, select a larger label so that both have tiny grey boxes at their corners.  Then click 
on each icon in turn.

Align or Space Toolbar

The Align or Space toolbar is useful when two or more components need to be positioned 
uniformly. 

For example:
The tool bar can be used to aligned several components so that the tops are all in line or 
space components so that they have an equal amount of space between them. 

The first component selected determines the position to which the others will align.

T I P
The trick is to ensure that the thick black line on the icon represents the border that you want to have 
aligned.

I M P O R T A N T
Alignment always occurs based on the first component you select when you are selecting 
multiple components

1 Align Left Edges aligns a group of components with the leftmost position of the 
component that was first selected.

2 Align Horizontal Centres centres a group of components based on the horizontal 
centre of the first-selected component.

3 Align Right Edges aligns a group of components with the rightmost position of the 
first-selected component.

4 Align Top Edges aligns a group of components with the topmost position of the first-
selected component.

5 Align Vertical Centres aligns a group of components based on the vertical centre of 
the first-selected component.

6 Align Bottom Edges aligns a group of components with the bottommost position of 
the first-selected component.

7 Space Horizontally spaces a set of components based on the leftmost position of the 
first-selected component and the rightmost position of the last-selected component.

Align Palette
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8 Space Vertically spaces a set of components based on the topmost position of the 
first component selected and the bottommost position of the last component 
selected.

9 Centre Horizontally in Band centres a component horizontally within a band.

10 Centre Vertically in Band centres a component vertically within a band.

N O T E
When moving fields around by dragging, you will notice that lines keep appearing. These 
are alignment aids which allow you to line up components using the pallette tools.

Advanced Component Palette

The Advanced Component palette contains components that can help you manage 
complex reporting layouts.

1 Region logically groups components together. To achieve this, you need to place the 
region on the canvas first and then place the other components on top of it. This 
defaults to having a line around it but the option No line can be selected from the 
Line Colour tool.  When the region is moved, all the components in it move with it.  
When the region is made invisible, all components in it are also hidden.

2 Sub Report handles multiple master details, creates side-by-side reporting effects 
and link reports with different data sources together as one. This is discussed in 
detail the Clarity (Advanced) Course.

3 Page Break allows advanced control over pagination.

4 Paint Box is a new feature in v8.2.

Advanced Palette
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5 Crosstab allows the user to generate a set of calculations that summarize grouped or 
aggregated data from database tables and provide a way of extracting a great 
amount of information from data. Crosstab reports display the calculations in a grid 
format similar to the following illustration:

Report Tree
The Report Tree can be used to view the components within each band of the report in a 
tree-like structure. Components selected in the Report Tree become the selection in the 
report layout. 
You can rename components by right-clicking on the name, selecting Rename and then 
typing in a new name. Make sure to hit the ENTER key after renaming to ensure that the 
new name is assigned. Renaming objects is useful if you are planning to use them in 
calculations or formulae.
This tool window is dockable only on the left and right sides of the design workspace.

Cross Tab Function
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When selected, the properties of the component are also displayed and can be altered.

1 Report tree shows each object on the form in a tree structure.

2 Properties list shows advanced properties for the currently selected object. If the 
report itself is selected then it shows the report properties.

The Data Tree
The Data Tree can be used to create data-aware components within a band. Simply select 
a set of fields and drag the selection into the band. A set of corresponding data-aware 
components will be created. This tool window is floating and dockable only on the left and 
right sides of the design workspace.

1 Data Tree shows all of the data pipelines in the data workspace, as well as three 
special data sources: plGlobalVars, plParams and plTemplate.

2 Field List shows the EXO Business database fields available. Individual fields can be 
dragged from here onto the report.

Report Tree
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Data Tab
This view shows what data is available from the currently selected data pipeline. The 
screen shot below illustrates how the Data Tree looks when the Data tab is selected.  You 
can drag fields directly from here onto your report canvas to create a DBText component 
linked to the selected data field.

Layout Tab
The Layout tab allows you to control the format of the components created when you drag 
fields from the Data Tree into the layout.  You can create just a Label, just a DBText or both 
for each field you drag from the Data tab.  You can also specify the orientation of the label 
relative to the DBText as well as the font size and style to use.

Report Menu
The Report dropdown menu includes a number of features that are not covered in 
tutorials, but are highlighted here.

Data Tree
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Title
The Title band does not appear in the default Design canvas. It needs to be selected here 
to activate it. The Title band serves the same purpose as the Header band, except that it 
only prints on the first page and not on subsequent pages. If both Title and Header are 
activated, the Title band appears above the Header band.

Summary
The Summary band always appears below the last line of information on the report. The 
two options are to print it directly below the last line of information or to print it just 
above the Footer on the last page. (Summary to Bottom option on the Tools menu) 
Although, on the canvas, the Footer appears above the Summary band, when the report is 
printed, the Footer is printed at the bottom of each page and is always the last item 
printed.

Header / Footer
The Header and Footer appear at the top and bottom of each page respectively.  These 
menu options allow you to show or hide these sections.

Page Style
This band, when activated, appears at the bottom of the canvas. Anything entered in this 
band appears 'behind' the report, similar to a watermark.  Hence, if you need lines to run 
the length of an invoice or a border around the page, you would add these to the Page 
Style band. 

Report Menu
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Groups
The Groups menu item allows you to set up groups in your report.  This is described more 
in Unit 3, ‘Tutorial 2: Invoice Listing Report’, on page 51. Grouping is similar in purpose to 
the Groups tab in the Data view when setting up a data pipeline, however, this option is 
easier to implement and understand when creating basic reports.  Remember that in order 
to group things here, they must be sorted by the same fields and in the same order in your 
data pipeline.

Outline Settings
The Outline settings property once enabled, is available only in the preview tab of the 
Clarity designer. It shows a tree view display of the various groups in the report and 
optionally the pages they appear on. Clicking the groups or the page numbers takes the 
user directly to the appropriate page.

Outline Settings
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Find Text Settings
This option is only available in the Preview tab. It provides the user with the ability to 
search for strings within the report.

The user can specify whether the search will be case sensitive or whole word, whether the 
starting page for the search would be the first page or the current one. The Default Find 
Text String can also be specified.

Portrait / Landscape
This is a quick way of setting the orientation of the report on the page.  Another method is 
to go into the File > Page Setup menu item and change it on the Paper Size tab.

Pass Setting
There are two options available:

Find Text Settings

Find Text Preview
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• One pass, or 

• Two passes.  

This is an advanced setting that beginner Clarity users shouldn't get too concerned with.  
Basic reports should run fine on either setting, although, for large reports, you may notice 
reports run more slowly when set to Two Pass.  Using Two Pass, the computer goes 
through the data twice - doing all the calculations out on the first pass and then formatting 
and printing the report on the second pass. One Pass does it all in one go.  You may find 
that in complex reports this setting needs to be taken into account to ensure, for example, 
that variables are not calculated twice (when set to Two Pass) or that report totals are 
calculated incorrectly before generating (if set to One Pass).

Units 
A number of different units of measurement are available to select from. These apply to all 
reporting features (custom page size, position of labels etc.).

Units List
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Tools Menu

Report manager
The Report Manager tool makes the management of reports much easier in DCE situations 
where there is no access to the shared folders on other systems. In such cases, with the 
help of the Report Manager, reports are stored in the database as BLOBS. The user can 
perform batch import/exports as well as single file import/export of clarity files.

Using the Report Manager, there is a consistency in terms of the versions of the reports on 
all systems thereby eliminating problems with report editing/version control and making 
management of reports easier.
On the down side, the download of reports becomes slower because the reports are 
extracted from the database and then run. For the EXO Business software to refer to the 
Clarity files stored in the database rather than the files stored in the default/custom Clarity 
directory turn on the profile Store Clarity Files in DB.

Runtime Parameters
Setting up of the runtime parameters are discussed in Unit 4, ‘Runtime Parameters’, on 
page 59.

Convert to Menu

Report Manager
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Convert 
FMT Conversion is used to convert legacy FMT files
Custom report Conversion allows the user to create a new custom report by selecting 
from the predefined set of reports.
The Convert Report (Stockcode) utility converts the clarity reports to 23 characters stock 
code.
The Convert Report (IB <---> MSSQL) utility converts a legacy Interbase report to an 
MSSQL one and vice versa.  Note that Interbase reports are only supported up to EXO 
Business version 6.2.
The GL Report Conversion utility creates clarity forms for the reports written in the GL 
report writer. 

SQL to Report
This tool allows the user to generate a report based on an SQL statement. The user simply 
has to specify an SQL statement and follow the steps of the utility to generate a report 
based on it.

Validate Report
This performs a basic check on the validity of the report (fields, links, code, etc.) and gives 
“No error found" a message if validation is completed successfully.  It is a good idea to run 
this before you save your reports. There are still errors and inconsistencies that this tool is 
not able to warn you about. You should check reports manually and preview them.

Summary to Bottom
This option determines whether the Summary band of your report appears immediately 
after the last Detail item on your report (not selected) or at the bottom of the page, just 
above the Page Footer (selected).

Switch
This option allows you to switch the report between Custom Report and Standard Report.  
This determines whether the report is stored in the EXO Business database as a Custom 
report or a Master/standard report and takes effect when EXO Business is set up to store 
report definitions in the database rather than in files.

Setting
The Setting option opens a window where you can enter the document name, a 
description, the number of copies that should be printed when output to a printer and a 
button to set advanced output options, including printing to multiple printers and/or 
paper trays.  This is covered in the Clarity (Advanced) course.
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Skills checklist
Tick the skills that you have learned in this unit.

Skills

Identify Clairty form types

Familiarise yourself with all work tabs

Canvas set up

Understand pallette tools

Utilise drop down menu options
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Tutorial 1: Stock 
Listing Report
In this unit you will learn 
how to building your first 
report in Clarity
By the end of this unit, you will be able to:

Create Data Tables

Add Fields

Position and Align items

Use the Preview Tab
 37
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Overview

This simple exercise provides an introduction to the EXO Business Clarity Report Designer 
basics, the Query Designer and the process of building reports. The purpose of this tutorial 
is to show you what it takes to build a report and to get an overall idea of the concepts. If 
you feel a little lost, don't worry. The meaning behind the actions will become clearer in 
later tutorials. 
The report for this tutorial should contain the following items:

• A list of stock items

• A selling price for each item

• A Latest cost for each item

• A GP% for each item
© Copyright 2012 MYOB Technology Pty Ltd
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Plan the Data Source

Before starting a report, take the time to plan the data source.

Which fields are required to create this report?

Which tables are needed to supply these fields?
All of the above fields can be found in one table:  Stock_Items.   

Item Fields Required

A list of stock items Stock_Item.Stockcode
Stock_Item.Description

A selling price for each 
item

Stock_Item.Sellprice1

A latest cost for each item Stock_Item.Latestcost

A GP% for each item No further fields required (GP% can be 
calculated by (Sellprice1-Latestcost) / 
Sellprice1 * 100)
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Create a new report

Start Clarity
It will be helpful for you to become familiar with the following steps as you will repeat this 
process to begin any report that you are writing from scratch (except FMT conversions).

1 Launch the Clarity Report Designer from the EXO Business > Reports Business Flow 
menu and via the dropdown menu Reports > Clarity Report Desginer.

2 Click on File > New Report or the blank document icon on the main toolbar.

3 Click on the Data tab.

4 Select File > New in order to access the New Items dialog.

5 Double-click on the Query Designer icon. The Query Designer will come up with a list 
of available tables.

In the Query Designer
1 Choose the Stock_Items table by double-clicking on it. This table should now appear 

in the list of Selected Tables. 

2 We have finished selecting tables for now, so select the Fields tab.

3 Note that all fields are preceded by the table name and a dot.
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4 Select the fields as listed below by double-clicking on them.

5 Click on the Calculations tab.

6 Double-click on the Latestcost field.

7 From the dropdown list in the Function column, change from Sum to Expression.

8 Enter the following calculation in the Expression field: (Sellprice1 -
LatestCost)/Sellprice1*100.

9 Change the name of the Field Alias to GP%.

10 Move to the Search tab and double-click on Sellprice1. In the box below, specify that 
Sellprice1 <> 0.  This is because there may be some zero selling price1's in the 
database and the computer is unable to divide by 0.

11 Move to the Sort tab and select the Stock Code field.

Data Fields Tab

GP% Calculation
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12 Move to the SQL tab and change the Name of the data source to Stock_Listing.

13 Click OK.

You've officially completed your first query via the Query Designer. You'll notice a 
new window in the upper left-hand corner of the data tab workspace. This is a data 
view of the query and represents the data that will be selected from the database 
each time the report is generated.  

14 Preview the data produced by this data source by using the Page and Magnifying 
Glass icon:

Second Data Query
We will now add another query to the same report and you will see that this additional 
query need not in fact be joined to our first query at all.

1 Click on File > New and choose Query Designer.

2 Choose the General_Info table by double clicking on it. 

Data SQL Tab

Preview Data
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T I P
You can type the letter G and the cursor will jump to General_Info in the list. General_Info contains 
the registered EXO Business company information and tax registration details required on many 
reports.

3 Move to the Fields tab and select the Username only. Click OK.

4 You are back in the Data tab and General_Info appears as a dataview on your Query 
tab.

Report Layout
1 Click the Design tab.

2 Clarity will need to know which query on the Data view tab represents the Primary 
detail section of your report.   This means it wants to know the main table on which 
you will be building the report. This is essential.  In our case, it is the first query we 
created via the wizard, called Stock_Listing.

N O T E
If you select the wrong table, don't panic - simply click on the Report menu and select 
Data…. The Primary Table Selection Screen will appear once again and you can change the 
table.

3 Select File > Save As… and save your report as StockItems.CLR.

Primary Table Selection
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Design Workspace/Report 
Canvas

The Design workspace (also known as the report canvas) is the environment in which you 
will build your report layout. The workspace is divided up into sections or bands, with each 
band's title and height-adjustment bar immediately below.

• The header band (the white space above the word 'Header') will appear at the top of 
each page of the report.

• The detail band will be the body of the report.

• The footer band will appear at the bottom of each page of the report. 

Begin the report
1 Click on the Label icon on the toolbar.

2 Click in the white space of the header band in order to create a label.

3 Create two more labels in the header band in the same fashion. The label will be 
aligned later.

4 Select Label1.

5 Locate the Edit toolbar (below the label component icon on the toolbar). It should 
contain the text Label1 in a white box, which is the caption of the currently selected 
label.

6 Highlight the text in the Edit toolbar and type Product.

7 Select Label2 and type Description into the edit toolbar.

8 Select Label3 and type Selling Price into the edit toolbar.

9 Continue placing labels for Latest Cost and GP% across the band.

10 Press CTRL + S to save your work.

Add Data fields
1 Select the Product label.

Label Palette Tool
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2 Hold down the SHIFT key and then click on the other labels. All the labels should 
now be selected. You can tell that they are selected by the small grey boxes at the 
corners of each label. These boxes are called selection handles.

3 Click the bold icon. All the label captions should turn bold.

4 Locate the DBText icon on the toolbar and click on it.

5 Place a DBText component in the detail band (click in the Detail band).

6 Change the text from bold to regular by clicking on the bold icon.

7 Place four more DBText components in the detail band.

8 Select DBText1.  Notice that there are two dropdown list in the Edit toolbar. The 
dropdown list on the left contains all the report data sources (Stock_Listing, 
General_Info and the three special data sources). The dropdown list on the right 
contains the fields.

9 Select Stock_Listing from the left dropdown list and select Stockcode from the right 
dropdown list. 

10 Continue selecting fields Description, Sellprice1, LatestCost & GP% in turn for 
DBText components 2-5.

Postioning
1 Right-click on the Product label (in the Header band) and select Position.

2 Set the Left to 5 and the Top to 5.

3 Click the GP% label and move it almost to the right hand margin of the report.

4 Select the Product label again, then hold down the SHIFT key and click on all of the 
labels remaining labels in the Header section.

5 Click the Space Horizontally icon.  The labels should now be spaced evenly across 
the report.

T I P
You can manually adjust lables fields that require more space at a later time.

DBText Palette Tool

Space Horizontally
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6 Click the Align Top icon. The labels should all align with the first label you selected.

7 Unselect all the labels by clicking on an empty space on the canvas.  Select the 
Product label again and then hold down SHIFT and select DBText1 (containing the 
StockCode field) and click the Align Left icon.  Repeat this step for the other labels 
and corresponding DBTexts but choose the Align Right icon for the numeric fields.  
(Ensure that the numeric components and their labels are right justified also).

8 Align the tops of all of the DBText components, as we did for the other labels.

9 Press CTRL + S to save your work.

Preview Window
The Preview window in the Report Designer environment works the same way as the 
preview capability in most other Windows applications. It shows you what your report will 
look when it is printed.

1 Click on the Preview tab and look at your report. Make sure that the columns are 
nicely spaced with plenty of room for long names. 

2 Everything should look good except for the rows, which are double- or triple-spaced. 
Double spacing takes up too much room and will waste paper when the report is 
printed.  Also you may wish to alter the number formats.

Tidying up
Even an advanced report writer will usually find several things that can be improved when 
previewing a new report. Let's fix the spacing to begin with.

Remove extra spaces
1 Return to the design workspace by clicking on the Design tab.

2 Press the left mouse button and draw an imaginary square around the fields in the 
details band of your report. The fields should all have grey dots ("handles") at each 
corner.  This indicates that it is part of a selection of multiple items.

Align Top
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3 Move one of the fields and notice how all of the fields move in unison, remaining in 
their relative positions to the field you are dragging. Move the fields to the top of the 
Details band.

4 Place your cursor over the bar labelled Detail. Your cursor will change to an up/down 
arrow, indicating that you can drag the section divider up and down.

5 Drag the divider (grey band) up until it meets the bottom of the components in the 
detail band.

Change number formatting
1 Right-click on the DBText component.

2 Select Display Format option.

3 Select the format you require. 

4 Click OK.

Final preview
Preview the report once more. If any of the fields are truncating their data then right-click 
and select the Autosize option.
You might wish to put the EXO Business company name on the top of this report. See if you 
can do this based upon what you've just learned.
Close the Report Designer window by clicking the button at the upper right corner of the 
window. You will be prompted to save your changes.

DBText Fields Positioning

Canvas Band Positioning
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Congratulations! You've built your first EXO Business Clarity report!

Final Preview
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Skills checklist
Tick the skills that you have learned in this unit.

Skills

Creating Data Tables

Adding Fields

Positioning and Alignment

Preview Tab Usage
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Tutorial 2: Invoice 
Listing Report
In this unit you will how 
to Use grouping 
effectively in reports.
By the end of this unit, you will be able to:

Use Grouping

Calculate Group Totals
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Overview

Groups are added to a report so that summary information can be extracted from 
specified subsets of data.  Grouping must be performed on discrete data fields, in other 
words, the data fields you group by must be able to be separated into distinct, identical 
groups.  An example of a field that cannot easily be grouped is a "datetime" field like 
Transdate.  This is because a datetime value can be any date or any time (down to 
fractions of a second).  While there are ways of grouping this data (e.g. by day or by hour), 
it is a complex topic beyond the scope of this course.  An example of a field that can be 
grouped is Accno - in other words, all records relating the same account will have the same 
Accno.
Groups are represented in the report layout by a matched pair of bands: the Group Header 
and Group Footer. The Group Header prints when the group begins and the Group Footer 
prints immediately after the last detail band of the group.  This process repeats itself until 
all groups have been processed.
You are able to group data in a report by more than one field but it is imperative that the 
fields that you group by are also fields that you sort by and in the same order or your 
report will not make sense.  Once the sort fields are properly set for the groups, extra sort 
fields can be added.  This may be required, for example, to sort by the DUEDATE field for 
debtor invoices which have been grouped by branch then by debtor.  In this case, your sort 
fields might be (in order): DR_TRANS.BRANCHNO, DR_ACCS.ACCNO, DR_TRANS.DUEDATE 
.
The report for this tutorial should list all the invoices, organised (grouped) by each debtor 
account.
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Data Source

The following tables and fields are required for this report:

Item Fields Required

Debtor Account Details DR_ACCS.ACCNO
DR_ACCS.NAME

Invoice Details DR_TRANS.INVNO
DR_TRANS.TRANSDATE
DR_TRANS.DUE_DATE
DR_TRANS.AMOUNT
© Copyright 2012 MYOB Technology Pty Ltd
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Data View

Create a data view consisting of required fields from the DR_Trans table and sort the data 
by Accno.

Data Sort Tab
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Grouping Data

1 Create a group based on the Accno field as shown below.

2 Click OK.

The following design layout is produced.  Compare the numbers on the screenshot below 
to the report preview to get an idea how the report groups are generated.

Report > Groups

Group Bands
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Report Layout

1 In the Group Header section, place the repeating data for each group, i.e. the 
account data (because the ACCNO is the same for each item in the group).  

2 In the Group Footer, place the summary data for each group, i.e. a dbCalc 
component displaying sum(Dr_Trans.amount).  

3 In the Detail section, place the invoice data (invno, amount etc…).

Your report should look something like this (perhaps with different fields).  Compare the 
design view and preview below.

Invoice Listing by Debtor - Report Layout
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Review Question: What could be improved on this report?

Review Question: What other fields might you add?

Invoice Listing By Debtor - Report Preview
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Skills checklist
Tick the skills that you have learned in this unit.

Skills

Use Grouping

Calculate Group Totals
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Runtime Parameters
In this unit you will learn 
how to Set up 
Parameters that can be 
specified by users when 
running reports.
By the end of this unit, you will be able to:

Use Combo Boxes

Use List Boxes

Use Text Boxes

Use Date Boxes

Explain the use of other parameter methods

Use available output options

Add Parameter Values to Reports
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Overview

This chapter shows how to create runtime parameters.  Runtime parameters allow users to 
add search criteria to a report at runtime.  Runtime parameters for a particular report are 
saved in a .CLS file with the same name as the report they are for.
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Parameter Set Up

Parameters Editor

To view the Parameters Editor:

1 From the Tools menu, select Runtime Parameters. 

2 The Parameters Editor window is displayed. A description of each field on the 
window is shown below.

Default Parameter Editor
© Copyright 2012 MYOB Technology Pty Ltd
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Fields Description

Parameter Name This is the name of the parameter that will be used 
when the parameter value is accessed in code on the 
Calc tab. This topic is covered in Clarity (Advanced).

Control Number This determines the order of the components when 
they show on the parameter dialogue box. 0 is first, 1 is 
second and so on.

Control Type The type of control that will appear on the Clarity 
Report Launcher (text box/combo box etc…). See item 8 
in the example below

Caption The caption that will appear alongside the control on 
the Clarity Report Launcher. The caption is important 
because it will describe to the user which field the 
selection criteria will control. See item 7 in the example 
below.

Table Analysis The name of the data pipeline that the selection criteria 
affect.

Key Field The field within the data pipeline that is filtered by the 
selection criteria.

Operator The search operator that is applied to the key field, e.g. 
equal/greater than/less than.

Default SQL for 
Key Field

Only used with Listbox, Combobox, Checkbox, Textbox 
and OrderBy components. The value that is entered into 
this list determines what is selected by default in the 
Listbox/Combobox when the Clarity Report parameter 
window pops up.
For OrderBy fields, this is a comma-separated list of 
fields that you can select to order your data by (the 
labels on this window change to reflect this when you 
select an OrderBy-type parameter).

Source SQL Only used with Listbox, Combobox and OrderBy 
components.  The SQL that will retrieve the values to be 
displayed in the Listbox/Combobox when the Clarity 
Report Launcher pops up. The name of the field for your 
"Key Field" must match one of the names of the fields in 
your source SQL statement.  If there's a difference (e.g. 
your Key Field is HDR_SEQNO and your combo has the 
field SEQNO), change "SEQNO" to "SEQNO AS 
HDR_SEQNO". This is called aliasing a field and allows 
Clarity to match that field to the Key Field.
For OrderBy parameters, this determines the default 
OrderBy field.
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An example parameter window is shown below.  Items 1 - 6 are selected when the desired 
parameters are set, to determine where the report is output to.  
The options are:

3 Print to printer/file

4 Preview to screen

5 Export data to file

6 View grid 

7 Send as attachment.

8 Export to XLS Report

The other fields are:

9 Caption

10 Parameter field

11 Enabled checkbox

Display Fields The fields that are highlighted in this field are the data 
fields that will be displayed in the Listbox/Combobox 
when the Clarity Report Launcher pops up. To enter 
values into this field, double-click on the SQL statement 
in the Source SQL box.  If it is a valid SQL statement, the 
list will automatically populate.  The Key field must be 
included in this list to be able to save the parameter.  Of 
the selected fields, you can determine which ones will 
actually show by Ctrl-clicking to select and unselect 
fields.

Enabled Whether or not the component is enabled by default.  
Enabling/disabling can also be achieved at runtime by 
selecting or unselecting the checkbox displayed 
alongside the component. See item 9 below.

Report Parameter Options
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Control types

Combo Box

This parameter would select all periods where the STOCK_ITEMS.STOCKGROUP field is 
greater than or equal to the stock group selected by the user in the From Secondary Stock 
Group dropdown list.
Notice that the default SQL uses "select min(groupno) from stock_groups", which gives us 
the first stock group as a default. Groupname and Groupno are the fields that are 
displayed in the dropdown list.

Combo Box Parameter
© Copyright 2012 MYOB Technology Pty Ltd

 64



Unit 4—Runtime Parameters
List Box

This parameter would select all records from DR_TRANS where ACCNO equals any of the 
accounts that the user has selected in the list box.  Notice the extra field "Visible lines", 
which tells Clarity how many lines you would like the list box to display.

List Box Parameters
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Check Box

This parameter would pass a true value to the report if the user selects the option.  Notice 
how this parameter is not tied to any data fields, so it does not affect the filtering.  Instead, 
this field is intended for use within Calc code. In this case it would be used to determine 
whether or not the detail is visible.

Check Box Parameter
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Text Box
This is another 'unbound' parameter.  It could be used to pass some text to the report 
which could then be printed in the header using a DBText field pointed to the plParams 
data source and the HeaderText field.  You could also add some default text which would 
print every time, unless the user decides to edit it.

Text Box Parameter
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Date

This parameter would select all records from Master where DR_INVLINES.TRANSDATE is 
less than or equal to the date selected by the user.  One alternative here is to put the word 
TODAY in the Default SQL field.  This would always default the selection to the current 
system date.

Others
Other parameter types are also available and some are new to Clarity in recent versions.  
These include:

Date Parameter

Parameter Description

OrderBy These parameters allow you to specify which field 
to sort the data by that comes to your report at 
runtime. It also offers a Desc or descending sort 
order flag.

DebtorSearch/CreditorSearch These parameter types allow the user to type a 
question mark ? to bring up the EXO Business 
Debtor or Creditor Search screen to select an 
account. These parameters always filter on Accno.

StockSearch This parameter type, like the previous type, brings 
up an EXO Business search box but for stock items.

GLAccSearch/GLAccGroupSea
rch

Same as above but for GL Accounts and Account 
Groups.
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DateRange This parameter allows users to select a date range, 
rather than just a single date value.  The operator 
should be "Between" when using this parameter 
type.

Spacer/Line These two are special parameters act as a vertical 
gap between parameters.  They have no 
functional use and is purely added for aesthetic 
reasons, allowing you to group similar parameters 
logically in the dialogue box.

AnalysisCodeSearch This parameter type, like the previous type, brings 
up an EXO Business search box but for Analysis 
Codes items.
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Displaying Parameter Values in 
reports

Parameter values may be displayed in a report using the DBCalc Component.  
Instead of selecting a data source, select plParams from the data pipeline name 
dropdown list and select ParameterNameValue from the data field dropdown list.  Clarity 
automatically suffixes the parameter name with 'Value' and then assigns it the value 
entered by the user.

DBText Parameter Selection
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Skills checklist
Tick the skills that you have learned in this unit.

Skills

Use Combo Boxes

Use List Boxes

Use Text Boxes

Use Date Boxes

Understand other parameter methods

Add Parameter Values to Reports
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More Reporting 
Functions
In this unit you will learn 
about extra reporting 
functions to build better 
reports.
By the end of this unit, you will be able to:

Perform Mutliple Table Joins

Create Calculated Fields

Limit content via search tab

Specify Sort Orders

Use Report Wizard

Hide Bands & Fields

Add paramters to a completed report

Add Report to EXO Business
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Overview

In this tutorial we are going to build a management report that summarises sales 
transactions in the EXO Business Database.  This tutorial demonstrates the use of multiple 
tables in a single data source, grouping data and runtime selection parameters.
© Copyright 2012 MYOB Technology Pty Ltd

 74



Unit 5—More Reporting Functions
Tutorial 3 - Sales Report

The questions are for a selected timeframe:

• What were the total sales per invoice and per customer?

• How much product was moved with each invoice?

We will answer these questions by selecting data at the line transaction level (DR_Invlines) 
and then use the report to summarize the data. 
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Planning the Data Source

Planning the data source first. 

Which fields are required to create this report?

Total Amount for each invoice line is calculated by Quantity * Unit price

Which tables are needed to supply these fields?
DR_Accs, DR_Trans, DR_Invlines

How are these tables linked?
DR_Trans.Accno = DR_Accs.Accno, DR_Invlines.Hdr_seqno = DR_Trans.Seqno

Items Fields Required

Customer name and 
number

DR_Accs.accno, 
DR_Accs.name

The Invoices for each 
customer DR_Trans.Invno

The quantity and total 
amount for each Invoice

DR_Invlines.StockCode, 
DR_Invlines.Description, 
DR_Invlines.Quantity, 
DR_InvLine.UnitPrice
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Building the Report

Task 1: Create a new Report
1 If you have an existing report open, go to the Design tab and select File > New 

Report. This creates a clean Design tab and a clean Data tab on which to create a 
new report. Had you selected File > New you would have retained your data queries 
from your previous report and only the report canvas would be cleared

2 Go to the Data tab.

3 Select File > New.

4 Double-click on the Query Designer icon.

5 Select DR_ACCS then DR_TRANS and you will see the join table box below.

6 Join the DR_TRANS table to the DR_ACCS table via the ACCNO field. This will mean 
removing all fields with common names leaving only the ACCNO fields.

7 Now add the DR_INVLINES table, inner joining DR_ INVLINES.HDR_SEQNO to 
DR_TRANS.SEQNO and again removing unnecessary join fields.

Table Joins
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8 The Query tab should then look like this:

9 Click on the Fields tab.

10 Click the following fields:  

•  DR_ACCS.ACCNO

•  DR_ACCS.NAME

•  DR_TRANS.INVNO

•  DR_INVLINES.STOCKCODE

•  DR_INVLINES.DESCRIPTION

•  DR_INVLINES.QUANTITY

•  DR_INVLINES.UNITPRICE

Task 2: Calculate the Total for Each Line Item
1 Click the Calcs tab.

2 Maximize the Query Designer.

3 Double-click on (or select) any field. If you are creating an expression, it does not 
matter which field you select as it is going to be overwritten by the expression that 
you type in.

4 Select Expression from the dropdown list in the Function column.

Data Joins Tab
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5 Enter the following calculation over the top of the wording expression: 

DR_INVLINES.UNITPRICE * DR_INVLINES.QUANTITY

6 Change the Name of the Field Alias to LineTotal.

7 Click on the Sort tab.

8 Because we are going to group the report by DR_ACCS.ACCNO (first) and then 
DR_TRANS.INVNO (second) you must sort the data by DR_ACCS.ACCNO (first) and 
then DR_TRANS.INVNO (second).

9 Click on the SQL tab.

10 You will be presented with the SQL script that prepares this data view for you. 
Rename the data view to Master and click OK (bottom right).

Task 3: Generate the Report via the Report Wizard 
method

1 Move to the design workspace via the Design tab

2 Select Master and press OK. You will see this dialogue whenever you move onto the 
design workspace when there are no objects on the canvas.

3 Select File > New. This creates a new report but retains the 'Master' data source that 
you just created).

4 Double-click the Report Wizard icon.

Line Total Calculation

Data Sort Tab
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5 Select all available fields by clicking the double arrow.

6 Click Next until you reach the screen with the chequered racing flag.

7 Select Modify the report's design.

8 Click Finish. The layout may look something like the image below.  Notice how some 
of the fields may not have been able to fit on a single line and the order is not very 
logical.  Re-arrange these fields and resize them so that they all fit, then resize the 
bands to eliminate the extra vertical space that is freed up.

9 Press CTRL + S and save the report under the name SalesReport.CLR

10 Preview the report. This report contains data in its raw form. The data doesn't really 
answer the proposed questions, but it does give us something we can transform into 
answers. Notice the data in the LineTotal column. We can use this total to compute 
the total per Invoice and per company.

Report Wizard

Format after using wizard
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Modify Basic Layout

Task 1: Calculate Total Amount for Each Company
1 Return to the design workspace.

2 Select Report > Groups.

3 Click Add.

4 Select the Master.ACCNO field as a group field and click Add to add it to the list of 
groups.

5 Click OK. A group header and group footer band will appear as two bands on the 
canvas. Notice the descriptions on these bands. The number shows which group the 
band belongs to and the word 'ACCNO' shows the field to which the group is 
assigned.

6 Separate the group footer band from the Detail band by dragging it downwards.

T I P
To set the font size and style for the next component you use, click on any exisisting component 
before clicking the toolbar to add a new component.  The new component will always pick up the size 
and style of the last component that was selected.

7 Place a DBCalc component in the Group Footer band and set it to calculate the sum 
of the LineTotal field. This gives us the total amount per debtor account.

8 Right-align the DBCalc component with the LineTotal DBText component in the 
Detail band and set all numeric components and their labels to right justified.

Task 2: Calculate Totals for Each Order
1 Select Report > Groups.

2 Click the Add button and then select Master.INVNO from the dropdown list and click 
Add.

3 Click OK. New group header and group footer bands are created for the INVNO 
group.

4 Separate the INVNO group footer from the Detail group Footer.

Line Total DBCalc
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5 Add two DBCalc components to the INVNO Group footer band and set them to 
calculate the sum of the Quantity and LineTotal fields respectively.

6 Right-align the DBCalc components with the corresponding DBText components in 
the detail band. 

Task 3: Fix the Repeating Fields
1 Select the Accno and Name DBText components in the detail band and move them 

into the Accno group header band.

2 Move the Invno DBText from the detail band into the invno group header band.

3 Preview the report. Now the customer and invoice information appears only once at 
the top of each corresponding group.
© Copyright 2012 MYOB Technology Pty Ltd
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Aesthetics

Task 1: Modify the Bands
The data in the detail band is not needed to answer the questions we posed at the 
beginning of this tutorial.
In fact, it adds unnecessary 'noise' to the report and makes it difficult to see the answers 
calculated in the group footer bands. We can resolve this issue by hiding the detail band.

1 Return to the design workspace.

2 RIGHT-CLICK over the white space of the detail band and select Visible, which will 
remove the check mark next to it and hide the detail band.

3 Preview the Report. Now only the totals are shown. However, the Invno appears on a 
separate blank line. It would be easier to read the report if we placed the Invno with 
the total.

4 Return to the design workspace.

5 Move the Invno DBText from the Invno Group header band to the Invno group 
footer band.  Now that the INVNO group header is empty, it too can be hidden.

6 The layout should look something like this:

Task 2: Set the Format of the DBCalcs 
1 Right-click over the LineTotal DBCalc in the Accno group footer band and select 

Display Format.

2 Select the first menu option with a dollar sign.

3 Do the same for the LineTotal DBCalc in the Invno group footer band.
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Task 3: Complete the Accno Group Footer Band 
1 Select the DBCalc components in the Accno group footer band and set the Font to 

bold.

2 Place a shape in the Accno group footer band.

3 Right-click and select Set to parent height & parent width.

4 Right-click and select Send the shape to the back.

5 Set the colour of the shape to light grey. The layout should look something like this.

Task 4: Put the Finishing Touches on the Report 
1 Delete the StockCode, Description and UnitPrice labels from the header.

2 Change the remaining header labels to be more readable.

3 Change the report heading from Master to Sales Report and right click > Autosize.

4 Set the Name field in the ACCNO header band to Autosize

Adding the grey bar

Report 3 Re-jigged
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5 Preview the report.

6 Save your changes CTRL-S.

Report 3 Preview
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Add Runtime Parameters

Task 1: Add period start -stop selection parameters
1 Select Tools > Runtime parameters.

2 Click on the  icon on the parameter toolbar.

3 Enter the parameter name StartDate 

I M P O R T A N T
Parameter names cannot contain spaces.

4 Select Date from the control type dropdown list.

5 Enter the Caption Enter Start Date.

6 Enter the Table Alias Master.

7 Select the Key Field DR_INVLINES.TRANSDATE from the field list.

8 Select the operator GreaterThanOrEqualTo.

9 Press the Save icon  on the toolbar.

10 Click on the  icon on the toolbar. Your parameter display should look like this:

Notice the option on the right hand side that allows you to select all dates by 
disabling this criterion at runtime.

11 Close this preview window.

Enter Start Date Parameter
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12 Add an EndDate parameter in the same way.

Task 2: Add account range selection parameters
1 Click on the Add button to add a new parameter.

2 Enter the Parameter name AccountStart. 

3 Enter the Caption Start From Account.

4 Select DebtorSearch from the control type,

5 Select MASTER as the Table Alias.

6 Select ACCNO as the the KeyField.

End Date Parameter
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7 Select the Operator GreaterThanorEqualto. 

8 Click on the the Save icon on the parameter toolbar. 

9 Now add a new parameter AccountEnd, similar to the AccountStart parameter but 
using LessThanorEqualTo as the operator.

Printing & Export to File
You will note from looking at the 'Output' menu that Clarity Reports can be printed in quite 
a number of different formats. Amongst these are Text, Excel and PDF. 
The following screenshot shows the icon that launches the Export to file feature. This icon 
is situated on the Clarity Report launcher on which you select your chosen parameters.

From Acount Parameter

Parameter Export
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Using the report you built in the above exercise, send the output to a PDF file. After you 
have run it, open up the resulting PDF file to ensure that you have all of the information.
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Adding Clarity reports to EXO 
Business Menus

Task 1: Add to EXO Business menu and launch
1 Save your report files in the Clarity Custom Form Directory. This is found by clicking 

Help > About on EXO Business's main menu. .

I M P O R T A N T
The .CLS file (parameter file) will have to be moved manually as simply saving a report to a 
different folder does not move the .CLS file.

2 Go to the menu designer. This may be found in ExoConfig > Staff > Drop Down

3 Menus or may exist as Utilities > Set Up Staff/Menus > Drop Down Menu Designer 
on your EXO Business menu.

4 Select Run Clarity Report from the list of procedures on the right-hand side. Drag 
and drop this to the menu column (branch) as you wish.

5 Enter the Caption that will appear on the menu (e.g. " Sales Report") and enter the 
name of your newly created Clarity report (e.g."SalesReport.CLR") in the 
Parameters edit box and press OK.

6 You may use the Up and Down buttons to reposition your report menu item.

7 Save the menus.

Folder Location
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8 Go back to EXO Business and refresh you settings using File > Refresh Settings.

Your menu option should appear in the menu that you dragged it to and you should be 
able to run the report by clicking on the menu item.
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Skills checklist
Tick the skills that you have learned in this unit.

Skills

Perform Mutliple Table Joins

Create Calculated Fields

Limit content via search tab

Specify Sort Orders

Use Report Wizard

Hide Bands & Fields

Add paramters to a completed report

Add Report to EXO Business
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Appendices
This unit provides 
additional information 
that will be useful when 
creating reports.
Appendix A: Database Primer

Appendix B: Key EXO Business Tables

Glossory
 93



Clarity (Beginners’) EXO Business
Appendix A - Database Primer

Overview of Databases
This appendix covers the bare basics of databases, with a brief introduction to the 
concepts of linking and joining.

Database introduction
A database is a collection of related data. A simple form of a database would be a phone 
book, with names, addresses & phone numbers.
The three most common types of databases are:

1 Flat Files  - All of the information is stored in one single file or table, like the phone 
book.

2 Object-oriented databases - data is stored as conceptual "objects" which hold links 
to other objects. An object may relate to any entity about which data may be held, 
such as a person, a company or an event.

3 Relational databases  - This is the type that EXO Business uses. Relational databases 
are a set of tables that are made up of rows and columns. Each table holds a 
different type of information in a number of columns or "fields".  A field is a basic 
structural unit of the database and represents a slot or space in which data can be 
placed. In good relational database design, very little information is duplicated from 
table to table and this means that to get meaningful data, you often have to link 
related data, such as Account details in one table (Name, contact details, etc.) with a 
second table of transactions.  This is best done with a join using a "key field", which 
is a number unique to the account and stored against each transaction.  One 
example of a key field is Account Number (Accno).  The remainder of this section 
deals with relational database concepts.

Joins and linking
When extracting data from more than one table, the tables need to be linked in order to 
get a meaningful set of information. The way the tables are linked is very important as 
there are various different types of joins that will produce different results.  Joins are best 
performed on Key fields, in one of the two tables, which are fields that have unique values 
for every row in the table:
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Outer Joins
Left Outer - returns all rows from the left (or "first" or "main") table with only the matching 
rows from the right table. Blank rows in the right table are returned for all the non-
matching rows from the left table. This kind of join is used frequently.
Right Outer - returns all rows from the right (or "second" or "child") table with only 
matching rows from the left table.  Blank rows in the left table are returned for all the non-
matching rows from the right table. This kind of join is not used very often.
Full Outer - returns all rows from both tables, matching the rows where possible and 
creating blank rows in both tables where there is no match found for the other.  This kind 
of join is sometimes used.

Inner Joins
Uses a comparison operator to match rows from two tables and only returns rows that 
match in both.

Self Join
Used to join a table to itself and used to reduce the number of queries when comparing 
different columns of the same table.
© Copyright 2012 MYOB Technology Pty Ltd

 95



Clarity (Beginners’) EXO Business
Appendix B - Key EXO Business 
Tables

Overview
This appendix outlines the basic structure of the key tables inside EXO Business and the 
major joins normally used. 

Debtors and Creditors
The structure in these tables is very similar and the relationships between related tables 
are identical. Where you see DR , substitute CR for the creditors system. The accounts are 
held in DR_ACCS, with transaction headers in DR_TRANS. The transaction headers store 
the summary information for transactions such as invoices and credits where multiple 
lines exist. The invoice number is stored, plus details like delivery address, total amount 
and so on. The common link between these tables is ACCNO. The next table, that often 
needs to be linked with these two, is the DR_INVLINES table. This holds the line detail, 
such as stock code, plus qty, unit price, unit cost (useful for margin reporting), tax and 
other details. It holds the ACCNO field, as well as INVNO for joining to the other two 
tables.
DR_ACCGROUPS - Stores the names of the account groups.
DR_ADDRESSES - Is for multiple delivery addresses, not normally needed in reporting.
DR_ALLOCATIONS - Stores information about allocating cash receipts and is used for multi-
currency.
DR_CONTACTS - Stores the information about individual contacts, if used.
DR_CONT_HIST - Stores notes about the contacts.
DR_LINE_DISCOUNTS and DR_PRICES - Store information about the more complicated 
pricing structures and discounts.

Stock
The stock tables are considerably simpler than debtors and creditors, but follow the same 
principles.
STOCK_ITEMS - Stores the details of the stock items, price, availability, supplier details
STOCK_GROUPS - Stores the names of the stock groups
STOCK_TRANS - Stores transactions, with quantities, costs and references
STOCK_LOCATIONS - Stores details of the different warehouses, if required.
STOCK_SERIALNOS - Store serial number information if required.
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STOCKTAKE_CTRL & STOCKTAKE_TOTALS - Are used for stocktaking and are not normally 
referred to in reporting.

General Ledger
The general ledger subsystem is also relatively simple.
GLACCS - Holds the account master file information, with the nature of the account 
(balance sheet, dr/cr, taxstatus). 
GLTRANS - Stores the transactions
GL_ACCGROUPS - Holds the group names.
GL_SUBACCS - Stores master-file information about the sub accounts, if used
GL_CONTROL - Stores various control file settings
There are also a range of tables for storing information about the general ledger reports 
and budgets.

Sales Orders and Purchase Orders
These are two pairs of tables, like the debtor and creditor transactions, they require a 
header and line table. SEQNO is used as the order number.
SALESORD_HDR - Is the header table with information on delivery address, customer order 
number and other reference items.
SALESORD_LINES - Contains the information about individual products ordered, quantity, 
price, supplied, invoiced and any text entries.
PURCHORD_HDR - Is the header table with information on delivery address and other 
reference items.
PURCHORD_LINES - Contains the information about individual products ordered, quantity, 
price, supplied, invoiced and any text entries.
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Other Tables
There are a variety of other tables; many are self-explanatory. If you are unsure of what 
tables or fields are used for, view the data to check.

Common Joins

JOIN TABLE To Table

Table Field Field Table

DR_ACCS ACCNO ACCNO DR_INVLINES

DR_ACCS ACCNO ACCNO DR_CONTACTS

DR_ACCS ACCNO ACCNO DR_TRANS

DR_ACCS ACCGROUP ACCGROUP DR_ACCGROUP
S

DR_TRANS SEQNO HDR_SEQNO DR_INVLINES

DR_INVLINES STOCKCODE STOCKCODE STOCK_ITEMS

SALESORD_HDR ACCNO ACCNO DR_ACCS

SALESORD_LINE
S

HDR_SEQNO SEQ_NO SALESORD_HDR

SALESORD_LINE
S

STOCKCODE STOCKCODE STOCK_ITEMS

STOCK_ITEMS STOCKGROUP GROUPNO STOCK_GROUPS

STOCK_ITEMS SUPPLIERNO ACCNO CR_ACCS
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Glossary

This glossary defines the technical terms and concepts related to the MYOB EXO Business 
Clarity Report Designer

A
Advanced Component Palette   A toolbar that contains advanced components. 
Align   The act of setting components' positions so they line up with one another.
Align or Space Toolbar   A toolbar that allows you to align or space components so that 
they have a uniform appearance. Select View > Toolbars > Align or Space to launch this 
toolbar.
AutoSize   A speed menu option available for text components. When AutoSize is set to 
true, the component adjusts its width so that all of the text is displayed.

B
Band   A section of canvas that describes how part of the report will look. A band is 
labelled in the section divider immediately below it; thus, the first band is called the 
'header', the second is called the 'detail' and the third is called the 'footer'.
Barcode   A component in the Standard component palette that renders barcodes. Use the 
Edit toolbar to set the data to be encoded. Right-click and access Configure to select bar 
code types.
Bounding box   (1) A method of component selection by which you right-click your mouse 
and drag it so it encompasses the components to be selected. (2) The box that appears 
around the components to be selected as you drag your mouse.
Bring to Front   A speed menu option that allows you to move an object in front of other 
objects. Use this option to control the appearance of over-lapping objects.

C
Calcs tab   An advanced tab in the Query Designer used solely by EXO Business developers 
from which you can create a calculation based on the data in the database. 
Calcs page   A page in the Query Wizard that allows you to make a calculation based on the 
data in the database.
Calculation   An option in the Query Wizard /Query Designer that allows you to derive new 
data from existing database fields.
Canvas   The area in the design workspace that contains the reports layouts. The canvas is 
divided into rectangular areas called bands.
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Component   An element used to control how the report looks. Each component has a 
unique purpose. In order to place a component in the design workspace, click the icon on 
the component palette and then click on the white space of the band in which you want 
the component to appear. When a component is selected, an edit or drop-down list may 
appear in the upper left hand corner of the design workspace. This area provides different 
options depending upon the selected component. 
Configure   A speed menu option for the Crosstab component. It allows you to access the 
Crosstab Designer.
Crosstab   A component that presents summarized data in a grid format. Crosstabs are 
designed by right-clicking over the component and accessing the Configure option.
Crosstab Designer   The dialog displayed when the Configure option on the speed menu 
for the Crosstab component is selected. A Crosstab layout is created via this designer.
Crosstab Wizard   A tool in the design workspace that generates a report based upon the 
choices you make in the wizard. Access this tool by selecting File > New, then clicking the 
Crosstab Wizard icon.

D
Data-aware components   Components to which you can assign data fields. In the Report 
Designer, these components are prefixed by DB, meaning 'database'.
Data Component Palette   The palette from which you create data-aware components. 
Click on the icon and click on the canvas to create a data-aware component. 
Data module   A behind-the-scenes container for dataviews. When you want to copy data 
from one report to another, export the data module from the first report and import the 
data module into the second.
Data pipeline   A special kind of component that manages the connection to the database 
and supplies data to a report. It also controls which rows of data are used to generate the 
report. It represents an EXO Business database table or SQL query and provides data in the 
form of fields and records.  A Pipeline is opened automatically when you log into EXO 
Business.
Data traversal   The act of moving through the rows of a database table or data selection.
Data Tree   A toolbar used in the design workspace to access the data selected in the data 
workspace. Select View > Toolbars > Data Tree to launch this toolbar. 
Data tab   The tab that you access to select data.
Database table   A structure that facilitates the storage and retrieval of organized data.
Dataview   The visual representation of a query displayed on the data tab. It contains the 
data selected in the Query Wizard or Query Designer. Dataviews allow you to make 
changes to a query via the Query Designer, which can be accessed by clicking the icons in 
the dataview tool-bar.
DBComponents   Data-aware components that can retrieve data from a query. The DB 
prefix stands for database. Use the edit toolbar to choose data for a DBComponent. 
Design tab   The tab in which you create your report layout.
Detail Band   A band that prints once for every row of data.
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Display Format   A speed menu option available for textual components. This option 
allows you to display a value in a certain format (decimals with a dollar sign, for example). 
Right-click over a textual component to access the Display Format.
Dock   The act of dragging a toolbar to one side of the workspace and dropping it such that 
it 'sticks' to that side. A docked toolbar moves when you move or resize the Report 
Designer.
Draw Toolbar   A toolbar used to fill a component with colour or to colour the border 
around a component. 

E
Edit   A speed menu option for a Rich Text component that opens an application that 
allows you to open a file and format text.
Edit Toolbar   A toolbar that allows you to set the most important property of a 
component. This toolbar changes to select database fields for data-aware components, 
adjust lines for the line component, select shapes for the shape component and type text 
for the label component. 
Expression   It is used when creating a calculation. It allows you to create other fields 
based on the data from existing fields.

F
Floating window   A toolbar detached from the edge of the Report Designer and released 
so that it 'floats' in front of the Report Designer.
Footer Band   A band that prints (usually the page number, date, time) at the bottom of 
each page of the report.
Format Toolbar   This toolbar gives you the ability to modify text-based components in a 
number of ways. You can change the font style and font size. You can bold, italicise or 
underline the text. You can justify a word or sentence to the left of the margin or you can 
centre or right-justify text. You can also change the colour of the text. 

G
Group (1)A section of a report that contains a group header, detail and group footer band. 
Groups are assigned to a database field. Select Report > Groups to access the groups 
dialog. (2) A behind-the-scenes component that allows a report to be organized into 
separate sections, based on the value of a field.
Group Header Band   A band that contains the header for a group. The components in a 
group header band appear at the beginning of a group.
Group Footer Band   A band that contains the footer for a group. The components in a 
group footer band appear at the end of a group.
Guides   The lines on the horizontal and vertical ruler that move as you move the cursor 
over the canvas.

H
Header Band   A band that prints at the top of each page of the report.
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Highlight   To select text for editing. You highlight text by holding down the mouse button 
and dragging the cursor over text or by holding down the Shift key and pressing an arrow 
key.

I
Image   A component on the Standard component palette that displays graphics (such as 
bitmaps, GIFs and JPEGs).

K
Keep group together   An option in the group's dialog that sets the group so that the bands 
of the group will print on the same page

L
Label   A component useful for titles and headings. Use the Edit toolbar to set the text for a 
label.
Label Template Wizard   A tool that allows you to create mailing label reports by selecting 
printer information and choosing a label type.
Line   A component in the Standard component palette that displays a line. Use the Edit 
toolbar to set the line orientation.
Lines  A speed menu option for a memo that allows you to access the Memo Editor, from 
which you can open text only files.

M
MailMerge   An option that appears when you right-click over a Rich Text component. It 
allows you to import field values into the Rich Text component.
MaintainAspectRatio   A speed menu option available for images. It scales an image so 
that the height and width are adjusted based on the original image size.
Memo   A special kind of component that allows you to load text into it. Right-click over 
the memo and select Lines in order to load text.
Memo Editor   A dialog accessed via the memo component (right-click over the 
component and select Lines) that allows you to load and save text files.

N
Nudge Toolbar   This toolbar allows you to move a component or a group of selected 
components one pixel at a time. See page 100 for a complete description of this toolbar.

O
Orphan   (1) A component(s) that prints on a different page than the components within 
the same band or region. For example, if a DBText that's supposed to follow a DBMemo 
prints at the top of the next page rather than with the DBMemo, it is orphaned. (2) A 
group footer band that prints at the top of a page with no preceding detail bands.
Overflow   Occurs when a stretchable component prints on additional pages.
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P
Pagination   A speed menu option for a Crosstab component that allows you to choose 
Across then Down or Down then Across printing for the Crosstab report.
ParentHeight   A speed menu option that allows you to set the size of an object so that it 
matches the height of a band. Right-click over a component to select ParentHeight.
ParentWidth   A speed menu option that allows you to set the size of an object so that it 
matches the width of a band. Right-click over a component to select ParentWidth.
Position dialog   A speed menu option that allows you to change the size and position of 
an object. Right-click over a component to access the Position... dialog.
Preview   A tab workspace where you can preview the generated report to see how it will 
look when printed.
Properties   Settings for components such as font style, size and colour.
PipeLine   A connection to the EXO Business database opened automatically whenever you 
log into EXO Business.

Q
Query   A request for data using a language specific to databases called SQL. The Query 
Designer and Query Wizards create SQL queries as we choose the data we want for a 
report.
Query Wizard   A tool that allows you to select data for a report. 
Query Designer   A tool that allows you to make changes in the data selection.

R
Region   A special kind of component that can contain other components.
Report Tree   A toolbar that displays all of the components in a report. It is particularly 
helpful in organizing components within bands. 
Report Wizard   A tool that allows you to create a report by answering a few simple 
questions.
ReprintOnOverFlow  A speed menu option that sets a component so that it will reprint. 
For example, a memo has an accompanying label. If the label is set to ReprintOnOverFlow, 
it will reprint on each page of the memo's text. Right-click over a component to select 
ReprintOnOverFlow.
Rich Text   A component that allows you to print formatted text.
Rich Text Editor   A dialog box accessible via the Rich Text component that allows you to 
replace text with database fields.
Rulers   The design workspace has two rulers: the horizontal ruler and the vertical ruler. As 
you move a component in the workspace, you'll see a guide that tells you the location of 
the component on the rulers.

S
Select  To click on an object. (See 'highlight' as a contrasting term).
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Selection   A group of selected components.
Selection handles   When multiple components are selected, little grey boxes appear 
around the components. These selection handles indicate the objects that are selected.
Selection tool   A tool used to select one or more components within the layout. It can also 
be used to clear any selection (by clicking in the white space of a band).
Send to Back   A speed menu option frequently used with shapes that allows components 
to be moved to the background. If you want to use a shape as a background, use the Send 
to Back function.
Shift-click  A method of component selection where you hold down the Shift key and then 
click on components. You can also remove a component from a selection using this 
method.
ShiftRelativeTo   A speed menu option that allows you to associate components so that 
they print one after the other. This option is especially useful when you want one 
component (a memo, for example) to appear below another.
ShiftWithParent   A speed menu option that allows a static component to print after a 
stretchable component. Right-click over a component to select ShiftWithParent.
Size Toolbar   A toolbar that allows you to set all of the components in a selection to the 
same width or height. 
Sizing   The act of altering the size of a component with the sizing handles or the Position 
menu.
Sizing handles  The little black boxes that appear when an object is selected. If you drag 
your cursor over one of the sizing handles, the cursor will change to a double-sided arrow. 
You can then resize the component by holding down the mouse. 
Speed menu   The menu that appears when you right-click over a component. The menu 
options vary depending upon the component.
SQL Structured Query Language   The language that EXO Business uses to retrieve data 
from a database in an ordered form so that it can be used to create reports. 
Standard Component Palette   A toolbar that includes the most frequently used 
components for building reports. 
Standard Toolbar   A toolbar that contains standard functions, such as saving, opening and 
printing reports. 
Start new page   An option in the group's dialog that allows you to force a group onto a 
new page each time the group field changes value.
Static components   Components that print just as they appear in the layout.
Status bar   The bar at the bottom of the design tab that tracks the movement of selected 
components. It is useful for component placement and alignment in that it allows you to 
position components based on an exact measurement. It also displays the name of the 
selected component.
Stretch   A speed menu option that applies only to stretchable components. When set to 
true, the component will change size depending upon the amount of text it contains. 
Right-click over a component to select Stretch.
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Stretchable components   Components that change size according to the amount of text 
they contain. A DBMemo is a stretchable component. Right-click over a component to set 
Stretch to true.
StretchWithParent   A speed menu option that allows the selected component to change 
height according to the change in height of the band in which it resides. Right-click over a 
component to select StretchWithParent.
Style   A speed menu option for the Crosstab component that allows you to choose 
between Repeated Captions or Standard printing.
Subreport   A component that allows you to create a report within a report in order to 
show more levels of detail or to print several reports as one.
Summary Band   A band that prints once at the end of a report. The band is typically used 
to summarize data. Select Report > Summary to create this band. An invoice total would 
be in the summary band.
SuppressRepeatedValues   A speed menu option that prevents repeated values from 
printing.
System Variable  A component that allows you to display the page number, time, date and 
other useful information.

T
Tabular  A setting in the Data Tree layout tab that configures the drag and drop behaviour 
to create labels across the top of the page and data flowing down the page. The opposite 
of vertical.
Title Band   A band that prints once at the beginning of the report. Select Report > Title to 
create this band.
Title bar   The area at the top of a window that contains the window title and can be used 
to drag the window to a new position.
Toolbars   Tools that allow you to modify a report layout. Select View > Toolbars to see a 
list of all toolbars.

V
Vertical   A setting in the Data Tree layout tab that configures the drag and drop behaviour 
to create labels down the page and data across the page. The opposite of tabular.
Visible   A speed menu option that determines the visibility of an object. Right-click over a 
component to select Visible. If the Visible option is set to false, the component will not 
appear in the report.

W
Workbench   The area on the design tab that surrounds the canvas and contains tools used 
to modify the report layout...
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Skills checklist
Tick the skills that you have learned in this unit.

Skills

Identify Main Data Tables

Join Definitions

Understand Common Joins

Glossary of Terms
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